Soundproblem unter Ubuntu 11.04 [Geschlossen]

Melden
-
 humphry -
Hallo,

Ich bekomme keinen Ton unter Ubuntu 11.04, das selbe Problem hatte ich auch unter 10.01 und deswegen habe ich auch Ubuntu upgedatet.
Ubuntu erkennt die Soundkarte (HDI Nvidia),....aber mit Allen Anwendungen kriege ich keinen Ton raus, Liegt es an den Audio-Treiber ? Muss er aktualisiert werden?

Ich hoffe jemand, wird mir weiterhelfen können ?

Vielen Dank an euch

3 Antworten

Hallo,

als erstes führe ein Update aus und versuche via module-assistant neu Treiberpakete zu bauen:

sudo apt-get update
sudo apt-get install aptitude
sudo aptitude update
sudo aptitude safe-upgrade
sudo aptitude install module-assistant
sudo m-a prepare
sudo m-a a-i alsa-source



... dann restart
Hallo humphry,

Also ich habe leider nach Eingabe der letzten Befehlszeile eine Fehlermeldung bekommen:

In file included from include/linux/pci.h:58:0,
from /usr/src/modules/alsa-driver/acore/memalloc.inc:13,
from /usr/src/modules/alsa-driver/acore/memalloc.c:1:
/usr/src/modules/alsa-driver/include/linux/pci_ids.h:2:58: fatal error:
@CONFIG_SND_KERNELSRC@/include/linux/pci_ids.h: Datei oder Verzeichnis
nicht gefunden
compilation terminated.
make[5]: *** /usr/src/modules/alsa-driver/acore/memalloc.o Fehler 1
make[4]: *** /usr/src/modules/alsa-driver/acore Fehler 2
make[3]: *** [_module_/usr/src/modules/alsa-driver] Fehler 2
make[3]: Verlasse Verzeichnis « /usr/src/linux-headers-2.6.38-8-generic
»
make[2]: *** [compile] Fehler 2
make[2]: Verlasse Verzeichnis « /usr/src/modules/alsa-driver »
make[1]: *** [build-stamp] Fehler 2
make[1]: Verlasse Verzeichnis « /usr/src/modules/alsa-driver »
make: *** [kdist_image] Fehler 2
Hallo,


Ok , dann versuche folgendes :

sudo m-a update
sudo m-a prepare
sudo m-a a-i alsa-source